Apple Silicon Compatibility

RapidWeaver 8.8.0 and newer is a Universal app and compatible with both Intel and Apple Silicon based Macs.

To take advantage of RapidWeaver on M1 Macs you’ll want to make sure all your plugins are up-to-date. Stacks from YourHead Software is one of the most popular plugins for RapidWeaver and also available as a Universal build.

To take advantage of the huge speed gains that the M1 chip can bring, please make sure you are running RapidWeaver 8.8.0 and Stacks 4.2.0 or newer.

If some of your installed plugins are not Universal they will not run in the native version of RapidWeaver. 

If a plugin isn't compatible with Apple Silicon. You might get the following error: 

RapidWeaver Failed to load some plugins

PluginName: Couldn't obtain plugin principle class

To make older plugins (that are not Universal) run on an M1 Mac you'll need to install Rosetta for macOS. Apple has a guide on how to install Rosetta. along with information on how to enable it on a per App basis.

However, by running RapidWeaver under Rosetta you'll lose some of the huge speed improvements M1 chips can bring.

Please check with the developer of any plugin you're using to see if they are available as Universal builds. If they are not available we'd suggest looking for alternative plugins and stacks that can cover the features you're missing.

If you have any further questions about M1 Macs and RapidWeaver please visit our Support Forum.
Themes and stacks are already compatible with RapidWeaver on Apple Silicon as they contain no compiled code.
0%
0%